Verification Processing Delays
Incident Report for Ubble
Resolved
This incident has been resolved.
Posted Nov 14, 2024 - 06:16 UTC
Monitoring
Due to an unexpectedly high inflow, our identity verification backlog exceeds our current capacity and we will probably miss some short SLAs. We are doing our best to catch up and get back to normal as soon as possible.
Posted Nov 13, 2024 - 20:02 UTC
This incident affected: IDApp and API.