Verification Processing Delays

Incident Report for Checkout Identity Verification

Resolved

Everything is back to normal
Posted Mar 10, 2026 - 11:13 UTC

Monitoring

We are checking if everything is coming back to normal
Posted Mar 10, 2026 - 11:12 UTC

Identified

A fix has been applied and it seems better
Posted Mar 10, 2026 - 11:12 UTC

Investigating

Our identity verification backlog exceeds our current capacity and we are missing some SLAs. We are doing our best to catch up and get back to normal as soon as possible.
Posted Mar 10, 2026 - 10:56 UTC
This incident affected: IDApp and API.