Verification Processing Delays

Incident Report for Checkout Identity Verification

Resolved

This incident has been resolved.
Posted Aug 03, 2026 - 19:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 03, 2026 - 19:20 UTC

Investigating

Our cloud provider faces some networking issue and we are missing some SLAs. We are doing our best to catch up and get back to normal as soon as possible.
Posted Aug 03, 2026 - 19:10 UTC
This incident affected: IDApp and API.