Identification Processing Delays

Incident Report for Ubble

Resolved

This incident has been resolved.
Posted May 25, 2023 - 07:50 UTC

Identified

Our data processing infrastructure is running behind which is causing delays in our ID verifications.
Posted May 25, 2023 - 07:40 UTC
This incident affected: IDApp, API, and Dashboard.